收集 FileZilla FTP 記錄
本文說明如何使用 Bindplane 代理程式,將 FileZilla FTP 記錄擷取至 Google Security Operations。
FileZilla 是開放原始碼的 FTP 伺服器和用戶端,會產生含有連線詳細資料、檔案傳輸作業、驗證事件和工作階段活動的記錄檔。剖析器會使用 grok 模式從記錄資料中擷取欄位,並將這些欄位對應至統一資料模型 (UDM)。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式必須安裝在與 FileZilla 相同的主機上 (或有權存取 FileZilla 記錄檔路徑)
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- FileZilla 應用程式的管理員存取權
取得 Google SecOps 擷取驗證檔案
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分中的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為有效 (執行中)。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取 FileZilla 記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的所有內容替換為下列設定:receivers: filelog: file_path: '<PATH_TO>/filezilla-logs.log' log_type: 'file' exporters: chronicle/filezilla_ftp: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: FILEZILLA_FTP raw_log_field: body service: pipelines: logs/filezilla_ftp_to_chronicle: receivers: - filelog exporters: - chronicle/filezilla_ftp
設定參數
替換下列預留位置:
接收器設定:
file_path:FileZilla 記錄檔的完整路徑:- Linux:例如
/var/log/filezilla/filezilla-logs.log - Windows:例如
C:\Users\<username>\AppData\Local\FileZilla\filezilla-logs.log - 確切路徑取決於在 FileZilla 中設定的檔案名稱和位置 (請參閱「在 FileZilla 中設定記錄」)
- Linux:例如
匯出工具設定:
creds_file_path:擷取驗證檔案的完整路徑:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDendpoint:區域端點網址:- 美國:
malachiteingestion-pa.googleapis.com - 歐洲:
europe-malachiteingestion-pa.googleapis.com - 亞洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需完整清單,請參閱「區域端點」
- 美國:
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,以套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄中是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出 observIQ OpenTelemetry Collector。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄中是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
在 FileZilla 中設定記錄功能
- 使用 FileZilla 登入伺服器。
- 開啟 FileZilla 軟體。
- 依序前往「編輯」>「設定」。
- 從選單中選取「記錄」。
- 請提供下列設定詳細資料:
- 勾選「在訊息方塊中顯示時間戳記」核取方塊。
- 勾選「記錄到檔案」核取方塊。
- 檔案名稱:輸入檔案名稱並選取儲存路徑 (例如
filezilla-logs)。 - 選用:限制記錄檔大小:選取這個核取方塊,即可限制記錄檔可使用的空間大小。
- 選用:限制:輸入記錄檔的大小上限 (以 MB 為單位)。
- 按一下 [確定]。
重新啟動 FileZilla。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| 資料 | read_only_udm.metadata.description | 原始記錄 data 欄位內容。 |
| 資料 | read_only_udm.metadata.event_timestamp.seconds | 使用 grok 模式從 data 欄位擷取,並轉換為 Epoch 秒數。 |
| 資料 | read_only_udm.network.http.response_code | 使用 grok 模式從 data 欄位擷取。 |
| 資料 | read_only_udm.principal.hostname | 使用 grok 模式從 data 欄位擷取。 |
| 資料 | read_only_udm.principal.port | 使用 grok 模式從 data 欄位擷取。 |
| 資料 | read_only_udm.principal.user.userid | 使用 grok 模式從 data 欄位擷取,前提是值不是 not logged in。 |
| 資料 | read_only_udm.target.ip | 使用 grok 模式從 data 欄位擷取。 |
| 資料 | read_only_udm.target.process.pid | 使用 grok 模式從 data 欄位擷取。 |
| read_only_udm.metadata.event_type | 如果 target.ip 存在,請設為 NETWORK_FTP,否則請設為 GENERIC_EVENT。 |
|
| read_only_udm.metadata.log_type | 設為 FILEZILLA_FTP。 |
|
| read_only_udm.metadata.product_name | 設為 FILEZILLA。 |
|
| read_only_udm.metadata.vendor_name | 設為 FILEZILLA。 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。