[patch] mkcshadow improvements

Nathan Myers ncm@cantrip.org
Tue May 16 14:04:00 GMT 2000


On Tue, May 16, 2000 at 01:34:00PM -0700, Benjamin Kosnik wrote:
> > Since "we" are the implementor, "we" can choose to define any
> > instance of undefined behavior.  ...
> > But it's academic, because it doesn't seem safe enough 
> > to be useful.
> 
> I suppose this same property allows us to call this thing _C_ (reserved 
> for implementors) instead of _C_something_that_makes_sense_to_nathan?

But our right as implementors to define a global name "_C_" doesn't 
help if it's not safe enough to use.

I'll try to think of a name that is precise, safe, and innocuous.

Nathan Myers
ncm at cantrip dot org


More information about the Libstdc++ mailing list