Names of header include guards

Nathan Myers ncm-nospam@cantrip.org
Mon Jul 21 22:30:00 GMT 2003


On Tue, Jul 22, 2003 at 12:12:23AM +0200, Gabriel Dos Reis wrote:
> Nathan Myers <ncm-nospam@cantrip.org> writes:
> | In fact, it would be a Good Thing to have a suffix or prefix on 
> | the include guards that looks more or less random, to make it really 
> | unlikely to collide with platform names.  I'd welcome a patch that put 
> | suffixes like "_EXDRJVZQIO" on all our header guard names.
> 
> What I do not understand is why we removed the _GLIBPCPP prefix (or
> _CPP_BITS) instead of replacing it just with _GLIBCXX_.  what was the
> rationale? 

I agree.  "cvs annotate" shows that change occurring on July 5.  
I don't recall any discussion of such a proposal. 

Nathan Myers
ncm-nospam@cantrip.org



More information about the Libstdc++ mailing list