[RFC] Queries and frontends

Michael Snyder msnyder@vmware.com
Tue Jul 21 17:57:00 GMT 2009


Nick Roberts wrote:

> Here's a revised patch for my original request.  It doesn't help with issues
> relating to GDB/MI but just uses the "server prefix" instead of a special
> option.  I have used this trick previously (2007-07-10) to avoid setting the
> convenience variable $_ with breakpoints.  This seems appropriate as I think
> the "server" command was created many years ago by Tom Lord or Jim Kingdon for
> use with annotations.  I could add a suitable note to the documentation.

Kingdon, 1994: Not terribly well documented.


Mon Apr 11 10:44:35 1994  Jim Kingdon  (kingdon@deneb.cygnus.com)

         * main.c (main): Accept --annotate=N option and make --fullname
         the same as --annotate=1.
         (command_line_input): Print annotatation before and after prompt.
         * blockframe.c (flush_cached_frames): Print annotation.
         * Rename frame_file_full_name to annotation_level and move it from
         symtab.h to defs.h.
         * source.c (identify_source_line): If annotation_level > 1,
         change output format.
         * breakpoint.c: Print annotation whenever a breakpoint changes.
         * main.c: New variable server_command.
         (command_line_input): Parse "server " and set server_command.
         (dont_repeat): Check server_command.



More information about the Gdb mailing list