From: "ufuk (Ufuk Kayserilioglu)" Date: 2021-08-31T21:04:07+00:00 Subject: [ruby-core:105098] [Ruby master Feature#18136] take_while_after Issue #18136 has been updated by ufuk (Ufuk Kayserilioglu). I don't want to detract from the content of the proposal, nor do I want to bikeshed the name, but personally, `take_while_after` does not convey the meaning of this behaviour to me. Can I suggest an alternative name of `take_upto` that works in the opposite way? The `Integer#upto` method takes all the items including the limit, so Ruby devs should be familiar with what that means. So `take_upto` should be more obvious a name as to what it is doing: take all the elements up to when the condition succeeds. Your examples become: ```ruby (0..).lazy .map { |offset| get_page(offset, limit) } .take_upto { |response| response.count < limit } # the last will have, say, 10 items, but should still be included! .map { process response somehow } ``` ```ruby (0..).lazy .map { |offset| get_page(offset, limit) } .take_upto { |response| !response['can_continue'] } # the last will have can_continue=false, but still has data .map { process response somehow } ``` Note that your line comments always mention the negative condition, so the code examples are now more inline with their verbalizations. ---------------------------------------- Feature #18136: take_while_after https://bugs.ruby-lang.org/issues/18136#change-93509 * Author: zverok (Victor Shepelev) * Status: Open * Priority: Normal ---------------------------------------- Sorry, I already tried that once (#16441) but I failed to produce the persuasive example. So I am back with a couple of them, much simpler and clear than my initial. **The proposal itself:** Have `take_while_after` which behaves like `take_while` but also includes the last element (first where the condition failed). Reason: there are a lot of cases where "the last good item" in enumeration is the distinctive one (one where enumeration should stop, but the item is still good. **Example 1:** Take pages from paginated API, the last page will have less items than the rest (and that's how we know it is the last): ```ruby (0..).lazy .map { |offset| get_page(offset, limit) } .take_while_after { |response| response.count == limit } # the last will have, say, 10 items, but should still be included! .map { process response somehow } ``` **Example 2:** Same as above, but "we should continue pagination" is specified with a separate data key "can_continue": ```ruby (0..).lazy .map { |offset| get_page(offset, limit) } .take_while_after { |response| response['can_continue'] } # the last will have can_continue=false, but still has data .map { process response somehow } ``` **Exampe 3:** Taking a sentence from a list of tokens like this: ```ruby tokens = [ {text: 'Ruby', type: :word}, {text: 'is', type: :word}, {text: 'cool', type: :word}, {text: '.', type: :punctuation, ends_sentence: true}, {text: 'Rust', type: :word}, # ... ] sentence = tokens.take_while_after { _1[:ends_sentence] } ``` (I can get more if it is necessary!) Neither of those can be solved by "Using `take_while` with proper condition.", as @matz suggested here: https://bugs.ruby-lang.org/issues/16441#note-9 I typically solve it by `slice_after { condition }.first`, but that's a) uglier and b) greedy when we are working with lazy enumerator (so for API examples, all paginated pages would be fetched at once, and only then processed). Another consideration in #16441 was an unfortunate naming. I am leaving it to discussion, though I tend to like `#take_upto` from #16446. -- https://bugs.ruby-lang.org/ Unsubscribe: