From: "kddnewton (Kevin Newton) via ruby-core" Date: 2024-01-22T16:11:56+00:00 Subject: [ruby-core:116368] [Ruby master Misc#20201] Should `opt_reverse` be renamed? Issue #20201 has been reported by kddnewton (Kevin Newton). ---------------------------------------- Misc #20201: Should `opt_reverse` be renamed? https://bugs.ruby-lang.org/issues/20201 * Author: kddnewton (Kevin Newton) * Status: Open * Priority: Normal ---------------------------------------- When you use keywords with the &&= or ||= operator on a [] method call, it uses the `opt_reverse` instruction. For example: ``` ruby h[foo: 1] &&= 2 ``` This instruction is used regardless of if optimizations are on or off. (`--dump=insns_without_opt` and `RubyVM::InstructionSequence.compile_option = false` both don't turn it off.) e`opt_reverse` is also used within the peephole optimizer, so its naming makes sense in those cases. Should the instruction be renamed `reverse`/`stack_reverse`? -- https://bugs.ruby-lang.org/ ______________________________________________ ruby-core mailing list -- ruby-core@ml.ruby-lang.org To unsubscribe send an email to ruby-core-leave@ml.ruby-lang.org ruby-core info -- https://ml.ruby-lang.org/mailman3/postorius/lists/ruby-core.ml.ruby-lang.org/