From: "matz (Yukihiro Matsumoto)" Date: 2012-04-01T02:39:58+09:00 Subject: [ruby-core:44017] [ruby-trunk - Feature #5663][Feedback] Combined map/select method Issue #5663 has been updated by matz (Yukihiro Matsumoto). Status changed from Assigned to Feedback I am OK with the original map_select behavior, but I don't like the name #map_select. It is combination of -ect family name with map. I prefer the name #filter, but it might be confused by simple alias of select. Any idea? Matz. ---------------------------------------- Feature #5663: Combined map/select method https://bugs.ruby-lang.org/issues/5663#change-25545 Author: wycats (Yehuda Katz) Status: Feedback Priority: Normal Assignee: matz (Yukihiro Matsumoto) Category: lib Target version: 2.0.0 It is pretty common to want to map over an Enumerable, but only include the elements that match a particular filter. A common idiom is: enum.map { |i| i + 1 if i.even? }.compact It is of course also possible to do this with two calls: enum.select { |i| i.even? }.map { |i| i + 1 } Both cases are clumsy and require two iterations through the loop. I'd like to propose a combined method: enum.map_select { |i| i + 1 if i.even? } The only caveat is that it would be impossible to intentionally return nil here; suggestions welcome. The naming is also a strawman; feel free to propose something better. -- http://bugs.ruby-lang.org/