From: "mame (Yusuke Endoh)" Date: 2012-12-09T21:07:37+09:00 Subject: [ruby-core:50708] [ruby-trunk - Feature #7517] Fixnum::MIN,MAX Issue #7517 has been updated by mame (Yusuke Endoh). Still, I'm not sure what problem (in mruby?) is resolved by the existence of Fixnum::MAX. How: n3 = n1 + n2 raise "unboxed" if n3 > Fixnum::MAX differs from: n3 = n1 + n2 raise "unboxed" if !n3.instance_of?(Fixnum) ? Just easier to read? -- Yusuke Endoh ---------------------------------------- Feature #7517: Fixnum::MIN,MAX https://bugs.ruby-lang.org/issues/7517#change-34553 Author: matz (Yukihiro Matsumoto) Status: Assigned Priority: Normal Assignee: matz (Yukihiro Matsumoto) Category: core Target version: 2.0.0 Maximum (or minimum) number of fixnum can not be get in portable fashion, so I propose Fixnum::MAX and Fixnum::MIN just like Float::MAX and Float::MIN. Matz -- http://bugs.ruby-lang.org/