From: "znz (Kazuhiro NISHIYAMA)" Date: 2013-07-27T15:25:47+09:00 Subject: [ruby-core:56221] [ruby-trunk - Feature #8499] Importing Hash#slice, Hash#slice!, Hash#except, and Hash#except! from ActiveSupport Issue #8499 has been updated by znz (Kazuhiro NISHIYAMA). =begin In attached patch.diff assert_equal({1=>2, 3=>4}, h.slice!(1, 3)) but ActiveSupport's h.slice!(1, 3) returns {5=>6}. http://api.rubyonrails.org/classes/Hash.html#method-i-slice-21 =end ---------------------------------------- Feature #8499: Importing Hash#slice, Hash#slice!, Hash#except, and Hash#except! from ActiveSupport https://bugs.ruby-lang.org/issues/8499#change-40709 Author: mrkn (Kenta Murata) Status: Assigned Priority: Normal Assignee: matz (Yukihiro Matsumoto) Category: core Target version: current: 2.1.0 =begin RD According to my experiences, the following two idioms often appeare in application codes. (1) (({hash = other_hash.select { |k, | [:key1, :key2, :key3].include? k }})) (2) (({hash = other_hash.reject { |k, | [:key1, :key2, :key3].include? k }})) On Rails, they can be written in the following forms by using ActiveSupport's features. (1) (({hash = other_hash.slice(:key1, :key2, :key3)})) (2) (({hash = other_hash.except(:key1, :key2, :key3)})) I think the latter forms are shorter and more readable than the former ones. So I propose to import the following methods from ActiveSupport: * (({Hash#slice})) * (({Hash#slice!})) * (({Hash#except})) * (({Hash#except!})) =end -- http://bugs.ruby-lang.org/