From: shugo@... Date: 2014-03-03T12:04:09+00:00 Subject: [ruby-core:61255] [ruby-trunk - Feature #5663] [Assigned] Combined map/select method Issue #5663 has been updated by Shugo Maeda. Status changed from Feedback to Assigned Yukihiro Matsumoto wrote: > I am OK with the original map_select behavior, but I don't like the name #map_select. > It is combination of -ect family name with map. > > I prefer the name #filter, but it might be confused by simple alias of select. > Any idea? What do you think of the following counter proposals? * select_yield * filter_map * map_if ---------------------------------------- Feature #5663: Combined map/select method https://bugs.ruby-lang.org/issues/5663#change-45595 * Author: Yehuda Katz * Status: Assigned * Priority: Normal * Assignee: Yukihiro Matsumoto * Category: lib * Target version: next minor ---------------------------------------- It is pretty common to want to map over an Enumerable, but only include the elements that match a particular filter. A common idiom is: enum.map { |i| i + 1 if i.even? }.compact It is of course also possible to do this with two calls: enum.select { |i| i.even? }.map { |i| i + 1 } Both cases are clumsy and require two iterations through the loop. I'd like to propose a combined method: enum.map_select { |i| i + 1 if i.even? } The only caveat is that it would be impossible to intentionally return nil here; suggestions welcome. The naming is also a strawman; feel free to propose something better. -- http://bugs.ruby-lang.org/