From: sawadatsuyoshi@... Date: 2019-12-26T23:13:30+00:00 Subject: [ruby-core:96506] [Ruby master Feature#16441] Enumerable#take_while_after Issue #16441 has been updated by sawa (Tsuyoshi Sawada). Dan0042 (Daniel DeLorme) wrote: > `take_while_after` is rather unwieldy, so in terms of naming maybe I can suggest: > > ```ruby > str.each_line(chomp: true).take_from{ _1 == '<<' }.take_upto{ _1 == '>>' } > ``` Such methods are the same as the cases 6 an 7 in my proposal #16446. ---------------------------------------- Feature #16441: Enumerable#take_while_after https://bugs.ruby-lang.org/issues/16441#change-83438 * Author: zverok (Victor Shepelev) * Status: Open * Priority: Normal * Assignee: * Target version: ---------------------------------------- The method is just like `#take_while`, but also includes the item where condition became true. Examples of usefulness: ```ruby str = <> epilogue DOC ``` Imagine we want to take everything starting from `<<` to `>>` in short and clean Ruby. Surprisingly, our best guess would be infamous flip-flop: ```ruby str.each_line(chomp: true).filter_map { _1 if _1 == '<<'.._1 == '>>' } # => ["<<", "1", "2", "3", ">>"] ``` Trying to achieve this with `Enumerator`, you _almost_ can express it, but the last line is lost: ```ruby str.each_line(chomp: true).drop_while { _1 != '<<' }.take_while { _1 != '>>' } # => ["<<", "1", "2", "3"] ``` So, Enumerable leaves us with this (which is harder to read, due to additional `.first`): ```ruby str.each_line(chomp: true).drop_while { _1 != '<<' }.slice_after { _1 == '>>' }.first # => ["<<", "1", "2", "3", ">>"] ``` With proposed method: ```ruby str.each_line(chomp: true).drop_while { _1 != '<<' }.take_while_after { _1 != '>>' } # => ["<<", "1", "2", "3", ">>"] ``` The idea is the same as with flip-flops `..` vs `...` (sometimes we need to include the last element matching the condition, sometimes don't), and `while ... end` vs `do ... while`. Another example (from `Enumerator.produce` [proposal](https://bugs.ruby-lang.org/issues/14781)): ```ruby require 'strscan' scanner = StringScanner.new('7+38/6') Enumerator.produce { scanner.scan(%r{\d+|[-+*/]}) }.take_while { !scanner.eos? } # => ["7", "+", "38", "/"] Enumerator.generate { scanner.scan(%r{\d+|[-+*/]}) }.slice_after { scanner.eos? }.first # => ["7", "+", "38", "/", "6"] Enumerator.produce { scanner.scan(%r{\d+|[-+*/]}) }.take_while_after { !scanner.eos? } # => ["7", "+", "38", "/", "6"] ``` PS: Not sure about the name, suggestions are welcome -- https://bugs.ruby-lang.org/ Unsubscribe: