Lab 3.5.1: Basic Frame Relay
Lab 3.5.1: Basic Frame Relay
Addressing Table
Default
Device Interface IP Address Subnet Mask Gateway
Fa0/0 192.168.10.1 255.255.255.0 N/A
R1
S0/0/1 10.1.1.1 255.255.255.252 N/A
S0/0/1 10.1.1.2 255.255.255.252 N/A
R2
Lo 0 209.165.200.225 255.255.255.224 N/A
S1 VLAN1 192.168.10.2 255.255.255.0 192.168.10.1
PC1 NIC 192.168.10.10 255.255.255.0 192.168.10.1
Learning Objectives
Upon completion of this lab, you will be able to:
• Cable a network according to the topology diagram
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 1 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
• Erase the startup configuration and reload a router to the default state
• Perform basic configuration tasks on a router
• Configure and activate interfaces
• Configure EIGRP routing on all routers
• Configure Frame Relay encapsulation on all serial interfaces
• Configure a router as a Frame Relay switch
• Understand the output of the show frame-relay commands
• Learn the effects of the debug frame-relay lmi command
• Intentionally break and restore a Frame Relay link
• Change the Frame Relay encapsulation type from the Cisco default to IETF
• Change the Frame Relay LMI type from Cisco to ANSI
• Configure a Frame Relay subinterface
Scenario
In this lab, you will learn how to configure Frame Relay encapsulation on serial links using the
network shown in the topology diagram. You will also learn how to configure a router as a Frame
Relay switch. There are both Cisco standards and Open standards that apply to Frame Relay.
You will learn both. Pay special attention in the lab section in which you intentionally break the
Frame Relay configurations. This will help you in the Troubleshooting lab associated with this
chapter.
Step 1: Cable a network that is similar to the one in the topology diagram.
You can use any current router in your lab as long as it has the required interfaces shown in the
topology. The Frame Relay labs, unlike any of the other labs in Exploration 4, have two DCE
links on the same router. Be sure to change your cabling to reflect the topology diagram.
Note: If you use 1700, 2500, or 2600 routers, the router output and interface descriptions appear
differently.
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 2 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
enable
configure terminal
no ip domain-lookup
enable secret class
banner motd ^CUnauthorized access strictly prohibited, violators
will be prosecuted to the full extent of the law^C
!
!
!
line console 0
logging synchronous
password cisco
login
!
line vty 0 4
password cisco
login
end
copy running-config startup-config
!R1
interface serial 0/0/1
ip address 10.1.1.1 255.255.255.252
shutdown
!The serial interfaces should remain shutdown until the Frame Relay
!switch is configured
!R2
interface serial 0/0/1
ip address 10.1.1.2 255.255.255.252
shutdown
!The serial interfaces should remain shutdown until the Frame Relay
!switch is configured
interface loopback 0
ip address 209.165.200.225 255.255.255.224
router eigrp 1
no auto-summary
network 10.0.0.0
network 209.165.200.0
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 3 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
_________________________________________________________________________
What is a DLCI used for?
_____________________________________________________________________________
_____________________________________________________________________________
What is a PVC and how is it used?
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
Step 1: Configure FR Switch as a Frame Relay switch and create a PVC between R1 and
R2.
This command enables Frame Relay switching globally on the router, allowing it to forward
frames based on the incoming DLCI rather than on an IP address basis:
FR-Switch(config)#frame-relay switching
Change the interface encapsulation type to Frame Relay. Like HDLC or PPP, Frame Relay is a
data link layer protocol that specifies the framing of Layer 2 traffic.
FR-Switch(config)#interface serial 0/0/0
FR-Switch(config)#clock rate 64000
FR-Switch(config-if)#encapsulation frame-relay
Changing the interface type to DCE tells the router to send LMI keepalives and allows Frame
Relay route statements to be applied. You cannot set up PVCs using the frame-relay route
command between two Frame Relay DTE interfaces.
FR-Switch(config-if)#frame-relay intf-type dce
Note: Frame Relay interface types do not need to match the underlying physical interface type. A
physical DTE serial interface can act as a Frame Relay DCE interface, and a physical DCE
interface can act as a logical Frame Relay DTE interface.
Configure the router to forward incoming traffic on interface serial 0/0/0 with DLCI 102 to serial
0/0/1 with an output DLCI of 201.
FR-Switch(config-if)#frame-relay route 102 interface serial 0/0/1 201
FR-Switch(config-if)#no shutdown
This configuration creates two PVCs: one from R1 to R2 (DLCI 102), and one from R2 to R1
(DLCI 201). You can verify the configuration using the show frame-relay pvc command.
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 4 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 5 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
Notice the 1 in the Inactive column. The PVC you have created does not have any endpoints
configured. The Frame Relay switch knows this and has marked the PVC as Inactive.
Issue the show frame-relay route command. This command shows any existing Frame Relay
routes, their interfaces, DLCIs, and status. This is the Layer 2 route that Frame Relay traffic takes
through the network. Do not confuse this with Layer 3 IP routing.
FR-Switch#show frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial0/0/0 102 Serial0/0/1 201 inactive
Serial0/0/1 201 Serial0/0/0 102 inactive
Step 2: Configure R1 for Frame Relay.
Inverse ARP allows distant ends of a Frame Relay link to dynamically discover each other and
provides a dynamic method of mapping IP addresses to DLCIs. Although Inverse ARP is useful, it
is not always reliable. The best practice is to statically map IP addresses to DLCIs and to disable
inverse-arp.
R1(config)#interface serial 0/0/1
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
Why would you want to map an IP address to a DLCI?
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
The command frame-relay map statically maps an IP address to a DLCI. In addition to mapping
IP to a DLCI, Cisco IOS software allows several other Layer 3 protocol addresses to mapped.
The broadcast keyword in the following command sends any multicast or broadcast traffic
destined for this link over the DLCI. Most routing protocols require the broadcast keyword to
properly function over Frame Relay. You can use the broadcast keyword on multiple DLCIs on
the same interface. The traffic is replicated to all PVCs.
R1(config-if)#frame-relay map ip 10.1.1.2 102 broadcast
Is the DLCI mapped to the local IP address or the IP address at the other end of the PVC?
_____________________________________________________________________________
R1(config-if)#no shutdown
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 6 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
Why is the no shutdown command used after the no frame-relay inverse-arp command?
_________________________________________________________________________
_________________________________________________________________________
_________________________________________________________________________
_________________________________________________________________________
R2:
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 7 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 8 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
R2:
R2#show frame-relay pvc
FR Switch:
FR-Switch#show frame-relay pvc
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 9 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
switched pkts 0
Detailed packet drop counters:
no out intf 0 out intf down 0 no out PVC 0
in PVC down 0 out PVC down 0 pkt too big 0
shaping Q full 0 pkt above DE 0 policing drop 0
pvc create time 10:28:31, last time pvc status changed 00:03:57
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 10 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
_____________________________________________________________________________
Issue the debug frame-relay lmi command. The output gives detailed information on all LMI
data. Keepalives are sent every 10 seconds, so you may have to wait until you see any output.
The debug output shows two LMI packets: the first outgoing, the second incoming.
R1#debug frame-relay lmi
Frame Relay LMI debugging is on
Displaying all Frame Relay LMI data
R1#
*Aug 24 06:19:15.920: Serial0/0/1(out): StEnq, myseq 196, yourseen
195, DTE up
*Aug 24 06:19:15.920: datagramstart = 0xE73F24F4, datagramsize = 13
*Aug 24 06:19:15.920: FR encap = 0xFCF10309
*Aug 24 06:19:15.920: 00 75 01 01 00 03 02 C4 C3
*Aug 24 06:19:15.920:
*Aug 24 06:19:15.924: Serial0/0/1(in): Status, myseq 196, pak size 21
*Aug 24 06:19:15.924: RT IE 1, length 1, type 0
*Aug 24 06:19:15.924: KA IE 3, length 2, yourseq 196, myseq 196
*Aug 24 06:19:15.924: PVC IE 0x7 , length 0x6 , dlci 102, status 0x2
, bw 0
R1#undebug all
Port Statistics for unclassified packets is not turned on.
Notice that the output shows an outgoing LMI packet with a sequence number of 196. The last
LMI message received from the FR Switch had sequence number 195.
*Aug 24 06:19:15.920: Serial0/0/1(out): StEnq, myseq 196, yourseen
195, DTE up
This line indicates an incoming LMI message from the FR Switch to R1 with sequence number
196.
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 11 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 12 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
.....
Success rate is 0 percent (0/5)
R1#*Sep 9 17:42:13.415: ICMP: echo reply sent, src 10.1.1.1, dst
10.1.1.2
R1#*Sep 9 17:42:15.411: ICMP: echo reply sent, src 10.1.1.1, dst
10.1.1.2
R1#*Sep 9 17:42:17.411: ICMP: echo reply sent, src 10.1.1.1, dst
10.1.1.2
R1#*Sep 9 17:42:19.411: ICMP: echo reply sent, src 10.1.1.1, dst
10.1.1.2
R1#*Sep 9 17:42:21.411: ICMP: echo reply sent, src 10.1.1.1, dst
10.1.1.2
As is shown by this debug message, the ICMP packet from R2 is reaching R1.
Why does the ping fail?
_____________________________________________________________________________
_____________________________________________________________________________
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 13 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
_____________________________________________________________________________
_____________________________________________________________________________
Replace the Frame Relay map statement and include the broadcast keyword this time. Verify
that the full routing table is restored and that you have full end-to-end connectivity.
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface serial0/0/1
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay map ip 10.1.1.2 102 broadcast
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
ia - IS-IS inter area, * - candidate default, U - per-user
static route o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.10.0/24 is directly connected, FastEthernet0/0
209.165.200.0/27 is subnetted, 1 subnets
D 209.165.200.224 [90/20640000] via 10.1.1.2, 00:00:05, Serial0/0/1
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0/1
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 14 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
<output omitted>
FR-Switch#show int s0/0/0
Serial0/0/0 is up, line protocol is up
Hardware is GT96K Serial
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Note the difference in output between the two show interface commands. Also notice that the
EIGRP adjacency is still up. Although FR Switch and R2 are using different encapsulation types,
they are still passing traffic.
Change the encapsulation type back to the default:
R2(config-if)#encapsulation frame-relay
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 15 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
Last Full Status Req 00:00:27 Last Full Status Rcvd 00:00:27
If you continue issuing the show frame-relay lmi command, you will notice the highlighted times
incrementing. When 60 seconds have passed, the interface changes its state to Up Down,
because R2 and FR Switch are no longer exchanging keepalives or any other link-state
information.
Issue the debug frame-relay lmi command. Notice that LMI packets are no longer showing up in
pairs. While all outgoing LMI messages are logged, no incoming messages are shown. This is
because R2 is expecting ANSI LMI, and FR Switch is sending Cisco LMI.
R2#debug frame-relay lmi
*Aug 25 04:34:25.774: Serial0/0/1(out): StEnq, myseq 20, yourseen 0,
DTE down
*Aug 25 04:34:25.774: datagramstart = 0xE73F2634, datagramsize = 14
*Aug 25 04:34:25.774: FR encap = 0x00010308
*Aug 25 04:34:25.774: 00 75 95 01 01 00 03 02 14 00
*Aug 25 04:34:25.774:
Leave debugging on and restore the LMI type to Cisco on R2.
R2(config-if)#frame-relay lmi-type cisco
*Aug 25 04:42:45.774: Serial0/0/1(out): StEnq, myseq 2, yourseen 1, DTE
down
*Aug 25 04:42:45.774: datagramstart = 0xE7000D54, datagramsize = 13
*Aug 25 04:42:45.774: FR encap = 0xFCF10309
*Aug 25 04:42:45.774: 00 75 01 01 01 03 02 02 01
*Aug 25 04:42:45.774:
*Aug 25 04:42:45.778: Serial0/0/1(in): Status, myseq 2, pak size 21
*Aug 25 04:42:45.778: RT IE 1, length 1, type 0
*Aug 25 04:42:45.778: KA IE 3, length 2, yourseq 2 , myseq 2
*Aug 25 04:42:45.778: PVC IE 0x7 , length 0x6 , dlci 201, status 0x2 ,
bw 0
*Aug 25 04:42:55.774: Serial0/0/1(out): StEnq, myseq 3, yourseen 2, DTE
up
*Aug 25 04:42:55.774: datagramstart = 0xE7001614, datagramsize = 13
*Aug 25 04:42:55.774: FR encap = 0xFCF10309
*Aug 25 04:42:55.774: 00 75 01 01 01 03 02 03 02
*Aug 25 04:42:55.774:
*Aug 25 04:42:55.778: Serial0/0/1(in): Status, myseq 3, pak size 21
*Aug 25 04:42:55.778: RT IE 1, length 1, type 0
*Aug 25 04:42:55.778: KA IE 3, length 2, yourseq 1 , myseq 3
*Aug 25 04:42:55.778: PVC IE 0x7 , length 0x6 , dlci 201, status 0x2 ,
bw 0
*Aug 25 04:42:56.774: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0/1, changed state to up
As you can see, the LMI sequence number has been reset to 1, and R2 began to understand the
LMI messages coming in from FR Switch. After FR Switch and R2 had successfully exchanged
LMI messages, the interface changed state to Up.
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 16 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
spoke topology would use a point-to-multipoint sub-interface. In this lab, you will create a point-to-
point sub-interface.
R2#ping 10.1.1.5
You can also verify the configuration using the show frame-relay pvc and show frame-relay
map commands in Task 4.
R1:
R1#show frame-relay pvc
PVC Statistics for interface Serial0/0/1 (Frame Relay DTE)
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 17 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
R2:
R2#show frame-relay pvc
PVC Statistics for interface Serial0/0/1 (Frame Relay DTE)
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 18 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
FR Switch:
FR-Switch#show frame-relay pvc
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 19 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
Unused 0 0 0 0
R1:
R1#show frame-relay map
Serial0/0/1 (up): ip 10.1.1.2 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
Serial0/0/1.112 (up): point-to-point dlci, dlci 112(0x70,0x1C00),
broadcast
status defined, active
R2:
R2#show frame-relay map
Serial0/0/1 (up): ip 10.1.1.1 dlci 201(0xC9,0x3090), static,
broadcast,
CISCO, status defined, active
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 20 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
FR Switch:
FR-Switch#show frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial0/0/0 102 Serial0/0/1 201 active
Serial0/0/0 112 Serial0/0/1 212 active
Serial0/0/1 201 Serial0/0/0 102 active
Serial0/0/1 212 Serial0/0/0 112 active
Note that two DLCIs are listed in the LMI message from FR Switch to R1.
R1#show run
<output omitted>
!
hostname R1
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 21 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
no shutdown
!
interface Serial0/0/1
ip address 10.1.1.1 255.255.255.252
encapsulation frame-relay
frame-relay map ip 10.1.1.2 102 broadcast
no frame-relay inverse-arp
no shutdown
!
interface Serial0/0/1.112 point-to-point
ip address 10.1.1.5 255.255.255.252
frame-relay interface-dlci 112
!
router eigrp 1
network 10.0.0.0
network 192.168.10.0
no auto-summary
!
!
banner motd ^CUnauthorized access prohibited, violators will be
prosecuted to the full extent of the law.^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
login
password cisco
!
end
R2#show run
<output omitted>
!
hostname R2
!
!
enable secret class
!
!
no ip domain lookup
!
!
interface Loopback0
ip address 209.165.200.225 255.255.255.224
!
!
interface Serial0/0/1
ip address 10.1.1.2 255.255.255.252
encapsulation frame-relay
clockrate 64000
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 22 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
FR-Switch#show run
<output omitted>
!
hostname FR-Switch
!
enable secret class
!
no ip domain lookup
frame-relay switching
!
!
!
!
interface Serial0/0/0
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay intf-type dce
frame-relay route 102 interface Serial0/0/1 201
frame-relay route 112 interface Serial0/0/1 212
no shutdown
!
interface Serial0/0/1
no ip address
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0/0 102
frame-relay route 212 interface Serial0/0/0 112
no shutdown
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 23 of 24
Exploration 4
Accessing the WAN: Frame Relay Lab 3.5.1 Basic Frame Relay
!
!
line con 0
password cisco
login
line aux 0
line vty 0 4
password cisco
login
!
end
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 24 of 24