0% found this document useful (0 votes)
32 views

Computer Network

The document describes the configuration of multiple routers to establish connectivity between networks using static and dynamic routing protocols. Router R1 is configured with DHCP pools to assign IP addresses to devices on the 10.0.0.0 and 20.0.0.0 networks. Routers R1, R2 and R3 have their interfaces configured and static routes established to allow communication between the 1.0.0.0, 2.0.0.0, 3.0.0.0 and 4.0.0.0 networks. RIP and OSPF routing protocols are also configured on routers to dynamically share routing information.
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
32 views

Computer Network

The document describes the configuration of multiple routers to establish connectivity between networks using static and dynamic routing protocols. Router R1 is configured with DHCP pools to assign IP addresses to devices on the 10.0.0.0 and 20.0.0.0 networks. Routers R1, R2 and R3 have their interfaces configured and static routes established to allow communication between the 1.0.0.0, 2.0.0.0, 3.0.0.0 and 4.0.0.0 networks. RIP and OSPF routing protocols are also configured on routers to dynamically share routing information.
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 19

Computer Network

LAB

R1#config t
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastethernet 1/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
DHCP pool for 10 Network
R1(config)#ip dhcp pool 10network
R1(dhcp-config)#network 10.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 10.0.0.1
R1(dhcp-config)#exit

DHCP pool for 20 Network


R1(config)#ip dhcp pool 20network
R1(dhcp-config)#network 20.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 20.0.0.1
R1(dhcp-config)#exit -

R1
Continue with configuration dialog? [yes/no]: n
Press RETURN to get started!
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int fa0/1
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shut
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2

R2
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int fa0/1
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shut

Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1
Router(config)#ip route 4.0.0.0 255.0.0.0 3.0.0.2

R3
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/1
Router(config-if)#ip address 3.0.0.2 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 4.0.0.1 255.0.0.0
Router(config-if)#no shut
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1
Router(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

PC>ipconfig
FastEthernet0 Connection:(default port)
Link-local IPv6 Address: FE80::240:BFF:FE20:9A3D
IP Address.: 1.0.0.2
Subnet Mask: 255.0.0.0
Default Gateway..: 1.0.0.1
PC>ping 4.0.0.2
Pinging 4.0.0.2 with 32 bytes of data:
Request timed out.
Reply from 4.0.0.2: bytes=32 time=13ms TTL=125
Reply from 4.0.0.2: bytes=32 time=22ms TTL=125
Reply from 4.0.0.2: bytes=32 time=11ms TTL=125
Ping statistics for 4.0.0.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 11ms, Maximum = 22ms, Average = 15ms

RIP

Router0(config)#router rip
Router0(config-router)# network 10.0.0.0
Router0(config-router)# network 192.168.1.252
Router0(config-router)# network 192.168.1.248

Router1(config)#router rip
Router1(config-router)# network 192.168.1.244
Router1(config-router)# network 192.168.1.248
Router2(config)#router rip
Router2(config-router)# network 20.0.0.0
Router2(config-router)# network 192.168.1.252
Router2(config-router)# network 192.168.1.244

OSPF

R1(config)#router ospf 1
R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
R1(config-router)#network 20.0.0.0 0.255.255.255 area 0
R1(config-router)#exit
R2(config)#router ospf 1
R2(config-router)#network 10.0.0.0 0.255.255.255 area 0
R2(config-router)#network 30.0.0.0 0.255.255.255 area 0
R2(config-router)#exit
R3(config)#router ospf 1
R3(config-router)#network 10.0.0.0 0.255.255.255 area 0
R3(config-router)#network 40.0.0.0 0.255.255.255 area 0
R3(config-router)#exit
R4(config)#router ospf 1
R4(config-router)#network 10.0.0.0 0.255.255.255 area 0
R4(config-router)#network 50.0.0.0 0.255.255.255 area 0
R4(config-router)#exit

R1#show ip ospf
R1#show ip ospf interface
R1#show ip ospf interface fastEthernet 0/0
R1#debug ip ospf events
R1#show ip ospf neighbor
R1#show ip ospf neighbor detail
R1#clear ip ospf process
R1#show ip ospf database
R1#show ip protocols
R1#show ip route

You might also like