summaryrefslogtreecommitdiff
path: root/contrib/pg_surgery/meson.build
diff options
context:
space:
mode:
authorAndres Freund2022-10-05 16:56:05 +0000
committerAndres Freund2022-10-05 16:56:05 +0000
commit902ab2fcef33b1e7c290af8d280e67d9f9212bcf (patch)
tree5797c322cf01409849f1ad3fbed4a1eb1a6760fa /contrib/pg_surgery/meson.build
parenta1261cd16f07f6db12a54b94d9e36175198951b4 (diff)
meson: Add windows resource files
The generated resource files aren't exactly the same ones as the old buildsystems generate. Previously "InternalName" and "OriginalFileName" were mostly wrong / not set (despite being required), but that was hard to fix in at least the make build. Additionally, the meson build falls back to a "auto-generated" description when not set, and doesn't set it in a few cases - unlikely that anybody looks at these descriptions in detail. Author: Andres Freund <[email protected]> Author: Nazir Bilal Yavuz <[email protected]> Reviewed-by: Peter Eisentraut <[email protected]>
Diffstat (limited to 'contrib/pg_surgery/meson.build')
-rw-r--r--contrib/pg_surgery/meson.build14
1 files changed, 11 insertions, 3 deletions
diff --git a/contrib/pg_surgery/meson.build b/contrib/pg_surgery/meson.build
index ac71caa5276..7b5c5999f4b 100644
--- a/contrib/pg_surgery/meson.build
+++ b/contrib/pg_surgery/meson.build
@@ -1,7 +1,15 @@
+pg_surgery_sources = files(
+ 'heap_surgery.c',
+)
+
+if host_system == 'windows'
+ pg_surgery_sources += rc_lib_gen.process(win32ver_rc, extra_args: [
+ '--NAME', 'pg_surgery',
+ '--FILEDESC', 'pg_surgery - perform surgery on a damaged relation',])
+endif
+
pg_surgery = shared_module('pg_surgery',
- files(
- 'heap_surgery.c',
- ),
+ pg_surgery_sources,
kwargs: contrib_mod_args,
)
contrib_targets += pg_surgery