summaryrefslogtreecommitdiff
path: root/src/test/modules/test_lfind/meson.build
diff options
context:
space:
mode:
authorPeter Eisentraut2023-03-03 06:18:20 +0000
committerPeter Eisentraut2023-03-03 06:45:52 +0000
commitb6a0d469cae4410a05b5e109748278065a931b68 (patch)
tree6324fe8028daa362b870740439c719bf71fa0116 /src/test/modules/test_lfind/meson.build
parentb1307b8b60111be8ddd8d6127701883c047bed15 (diff)
meson: Prevent installation of test files during main install
Previously, meson installed modules under src/test/modules/ as part of a normal installation, even though these files are only meant for use by tests. This is because there is no way to set up up the build system to install extra things only when told. This patch fixes that with a workaround: We don't install these modules as part of meson install, but we create a new "test" that runs before the real tests whose action it is to install these files. The installation is done by manual copies using a small helper script. Author: Nazir Bilal Yavuz <[email protected]> Discussion: https://www.postgresql.org/message-id/flat/2a039e8e-f31f-31e8-afe7-bab3130ad2de%40enterprisedb.com
Diffstat (limited to 'src/test/modules/test_lfind/meson.build')
-rw-r--r--src/test/modules/test_lfind/meson.build9
1 files changed, 3 insertions, 6 deletions
diff --git a/src/test/modules/test_lfind/meson.build b/src/test/modules/test_lfind/meson.build
index 79925359756..646ab4ab002 100644
--- a/src/test/modules/test_lfind/meson.build
+++ b/src/test/modules/test_lfind/meson.build
@@ -1,7 +1,5 @@
# Copyright (c) 2022-2023, PostgreSQL Global Development Group
-# FIXME: prevent install during main install, but not during test :/
-
test_lfind_sources = files(
'test_lfind.c',
)
@@ -14,14 +12,13 @@ endif
test_lfind = shared_module('test_lfind',
test_lfind_sources,
- kwargs: pg_mod_args,
+ kwargs: pg_test_mod_args,
)
-testprep_targets += test_lfind
+test_install_libs += test_lfind
-install_data(
+test_install_data += files(
'test_lfind.control',
'test_lfind--1.0.sql',
- kwargs: contrib_data_args,
)
tests += {