summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Evans <[email protected]>2023-08-23 14:43:06 -0700
committerJeremy Evans <[email protected]>2024-06-06 15:46:41 -0700
commit029d92b8988d26955d0622f0cbb8ef3213200749 (patch)
tree4f9f379c2f2732d7b52aa60dd02678364db5a7b4 /configure.ac
parent8f7d08137e91df1168a44e1b921bf035087ee85c (diff)
Disable __builtin_setjmp usage on linux-aarch64
It is questionable whether __builtin_setjmp should default to yes at all, but since it appears to still have problems on this platform, it seems safest to disable it. Fixes [Bug #14480]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2626c45920..f35fad6a36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1259,7 +1259,8 @@ main()
# __builtin_longjmp in ppc64* Linux does not restore
# the TOC register (r2), which is problematic
# when a global exit happens from JITted .so code.
- AS_CASE(["$target_cpu"], [powerpc64*], [
+ # __builtin_setjmp can have issues on arm64 linux (see [Bug #14480]).
+ AS_CASE(["$target_cpu"], [powerpc64*|arm64|aarch64], [
ac_cv_func___builtin_setjmp=no
])
# With gcc-8's -fcf-protection, RJIT's __builtin_longjmp fails.