summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Zhu <[email protected]>2024-09-04 13:47:03 -0400
committerPeter Zhu <[email protected]>2024-09-06 16:51:19 -0400
commit2865148a5aeb067ab8e1373a12c2f16de8cca0c9 (patch)
tree4f11f7109b795481b76918a038eda1cd9b7716f5 /configure.ac
parentb0adae7fb25cd0c2113c3498d384c1f0ffad5e6e (diff)
Revert "Check for both aarch64 and arm64 arch's for pac-ret"
This reverts commit 6a746e1bc902d4245aac58db4e9ffc2f72d79629. This patch breaks the C level backtrace on macOS ARM machines.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/11548
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 81788e47f8..884fe9a412 100644
--- a/configure.ac
+++ b/configure.ac
@@ -839,7 +839,7 @@ AS_IF([test "$GCC" = yes], [
])
# aarch64 branch protection
- AS_CASE(["$target_cpu"], [aarch64|arm64], [
+ AS_CASE(["$target_cpu"], [aarch64], [
AS_FOR(option, opt, [-mbranch-protection=pac-ret -msign-return-address=all], [
# Try these flags in the _prepended_ position - i.e. we want to try building a program
# with CFLAGS="-mbranch-protection=pac-ret $CFLAGS". If the builder has provided different