summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 498cde3f47..7d6ec072d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3986,11 +3986,11 @@ AS_CASE(["${ZJIT_SUPPORT}"],
],
[dev], [
rb_rust_target_subdir=debug
- ZJIT_CARGO_BUILD_ARGS='--features disasm,runtime_checks'
+ CARGO_BUILD_ARGS='--profile dev'
AC_DEFINE(RUBY_DEBUG, 1)
])
- AS_IF([test -n "${ZJIT_CARGO_BUILD_ARGS}"], [
+ AS_IF([test -n "${CARGO_BUILD_ARGS}"], [
AC_CHECK_TOOL(CARGO, [cargo], [no])
AS_IF([test x"$CARGO" = "xno"],
AC_MSG_ERROR([cargo is required. Installation instructions available at https://www.rust-lang.org/tools/install])